Forum Index > FlashYourWeb OS Support > Gallery 2 Bridge New Topic Post Reply
 Fatal Error Class'GalleryCoreApi'
 |  Printable Version
Anonymous: edwinb
 July 29 2009 22:05 PM (Read 2880 times)  



Hi there,

I just installed the bridge and play around with the albums and items. When I logged out and re-log in suddenly I received this message: Class 'GalleryCoreApi' not found in /home/........./plugins/G2Bridge/functions.inc on line 1459

Anybody can help me?

Thanks

Edwin


 
Quote
suprsidr
 July 30 2009 03:46 AM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

GL 1.4, 1.5 or 1.6?

If its where I'm looking functions.inc 1457 change:

PHP Formatted Code

        if(!isset($gallery)){
                G2B_G2_init();
        }
 

to
PHP Formatted Code

                G2B_G2_init();
 


-s


There will always be...
 
Profile Email Website
Quote
Anonymous: EdwinB
 July 30 2009 10:05 AM  


Thanks, It's tried but still doesn't work. I'm trying to re-install. I'm using GL 1.6 (any difference?).
By the way, when I unpacked the bridge, I could not find the config.php (plug ins outside public_html) ... am I missed something?

Thanks


 
Quote
suprsidr
 July 30 2009 11:02 AM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

For GL1.6 use the 1.5 version.
There is no config for 1.5+ plugins, the config options are online now in yoursite.com/admin/configuration.php

The function around line 1459 has to do with useralbums, this is not active by default.
So it leads me to believe your path to embed.php is not correct.

-s


There will always be...
 
Profile Email Website
Quote
Anonymous: EdwinB
 August 13 2009 18:38 PM  


Quote by: suprsidr

For GL1.6 use the 1.5 version.
There is no config for 1.5+ plugins, the config options are online now in yoursite.com/admin/configuration.php

The function around line 1459 has to do with useralbums, this is not active by default.
So it leads me to believe your path to embed.php is not correct.

-s



I've re-installed the bridge and re-start from beginning and working well for few weeks. And you are right it comes to the problem when I activate the useralbums.

I did change the script but it did not work. Just curious, the script on 1457 is :

if($_G2BCONF['user_albums']){

Did I miss something?

Where should I change the path for embed.php?

Thanks alot

Edwin


 
Quote
suprsidr
 August 13 2009 20:28 PM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

ok, try changing

PHP Formatted Code

if(!isset($gallery)){
                G2B_G2_init();
        }
 

to
PHP Formatted Code

                G2B_G2_init();
                global $gallery;
 


-s


There will always be...
 
Profile Email Website
Quote
Anonymous: EdwinB
 August 13 2009 21:36 PM  



Thanks, I'll try. However, infact I found 3 this same scripts in different lines/locations.... Shall change all the three? or just change one?

Thanks

Edwin


 
Quote
Content generated in: 0.16 seconds
New Topic Post Reply



 All times are PDT. The time is now 11:21 AM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Anonymous users can post 
HTML Allowed 
Censored Content