Forum Index > FlashYourWeb OS Support > MiniSlide Show New Topic Post Reply
 Links not working in minislideshow
 |  Printable Version
Anonymous: thirstyphoto
 October 09 2009 09:37 AM (Read 1814 times)  


I am using Gallery 2.3 and installed the Minislideshow on my wordpress sidebar. I swear the first time I installed it the links to the photos were working , but they dont anymore. What am I missing here? BTW, you can see it here live http://thirstyphoto.com/blog .

Oh yea.. Great little SWF!


PHP Formatted Code

<div style='text-align:center;'><div style='text-align:center;'>Showcase Photos</div><embed width="175" height="175" align="middle" pluginspage="http://www.macromedia.com/go/getflashplayer"
type="application/x-shockwave-flash" name="minislide" wmode="transparent" quality="high"
flashvars="xmlUrl=http://www.thirstyphoto.com/gallery/mediaRss.php?g2_itemId=508&shuffle=true&showDropShadow=true&delay=3&transInType=Fade&transOutType=Random&showTitle=bottom&roundedMask=true"
src="http://www.thirstyphoto.com/gallery/minislideshow.swf"></ embed ><div style='text-align:center;'>add <a href='http://apps.facebook.com/thirstyphoto/showcase/index.php'>this</a> to your Facebook Profile! click any photo to view it.</div></div>
 


 
Quote
suprsidr
 October 09 2009 10:25 AM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

I don't see anything wrong with your embed(except your not using swfObject) but I re-ran the embed-o-rator and the links work fine when I tested it:

PHP Formatted Code

<embed src="http://www.thirstyphoto.com/gallery/minislideshow.swf" width="160" height="160"
 align="middle" pluginspage="http://www.macromedia.com/go/getflashplayer"
type="application/x-shockwave-flash" name="minislide" wmode="transparent"
 allowFullscreen="true" allowScriptAccess="always" quality="high"
flashvars="xmlUrl=http://www.thirstyphoto.com/gallery/mediaRss.php?g2_itemId=508&shuffle=true&showDropShadow=true&delay=3&transOutType=Random&showTitle=bottom&roundedMask=true"></embed>
<noembed>Generated By <a href="http://www.flashyourweb.com/staticpages/index.php?page=embed-o-rator" target="_blank">The Acme MiniSlideShow EMBED-O-RATOR</a></noembed>
 


Adobe has almost made it hard to use flash these days as flasyplayer 10's security model does not allow for any cross-domain image manipulation.

-s


There will always be...
 
Profile Email Website
Quote
webmayin
 November 21 2009 04:30 AM  
Forum Junior
Junior

Status: offline

Registered: 09/18/09
Posts: 27

Thanks for all your previous help, I really appreciate it. I'm having trouble with links also.
www.dreadfulimagery.com
The minislideshow links to the actual Gallery page, and what I'd really like is to have them linked to url aliases I've set up to view the piclens slideshow as in
www.dreadfulimagery.com/nature
Do you know how I might put that link together so it makes sense?


 
Profile Email
Quote
suprsidr
 November 21 2009 06:04 AM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

There is the altLink option which is designed to replace all the links to the new alternate link.

There is also customLink where you setup a Custom Field foreach image called customLink which would contain your new link.

Also if you want the images to link to your embedded gallery instead the actual G2 installation, change the embedUri in mediaRss.php to that of your embedded gallery.

-s


There will always be...
 
Profile Email Website
Quote
Anonymous: webmayin
 November 21 2009 06:55 AM  


Thanks for that advice. I'm sure it will work amazingly, if I can get my links back.
Just after I posted, I changed my theme, stupidly, and now I get:
This album has no photos to show in a slideshow. Back to Album View
When I try to call the slideshow as a url. It works great when I call it from the Slideshow link on the left menu, but if I copy that link, and paste it in the address bar it errors out.
The theme I installed is PGtheme, and I notice it has it's own slideshow. I have uninstalled and removed it, and flushed the cache. Also I have downloaded and installed your slideshow modification. It works great, but I can't call it. Any ideas would be really appreciated


 
Quote
suprsidr
 November 21 2009 08:19 AM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

PGtheme was never updated for 2.3
It does not form the link correctly.
I give an example of how the links need to be represented here.

-s


There will always be...
 
Profile Email Website
Quote
webmayin
 November 21 2009 08:51 AM  
Forum Junior
Junior

Status: offline

Registered: 09/18/09
Posts: 27

That is awesome, thank you yet again. I ended up reinstalling rather than try wrestling it. It is working swimmingly, and beautiful. I'll follow that link you gave me and try and get the slideshows enabled for all of the albums on the main gallery page.
You rock.


 
Profile Email
Quote
webmayin
 November 21 2009 12:43 PM  
Forum Junior
Junior

Status: offline

Registered: 09/18/09
Posts: 27

The php code you posted in the link, Im guessing I can put that into node.tpl.php to get the same cooliris slideshow link appear in the album nodes.... Any tips you want to offer on that project would be appreciated ever so.


 
Profile Email
Quote
webmayin
 November 22 2009 23:06 PM  
Forum Junior
Junior

Status: offline

Registered: 09/18/09
Posts: 27

Okay, that didn't work out very well for me. I still suck at this. The only problem I have left with my site is that I want to have a page that displays all of my albums with a thumbnail teaser that links to the album page with a slideshow. If you look at www.dreadfulimagery.com you will see that the Nature and People links are linking up with the slideshow fine, and the user can get home by clicking on the logo, but the All Galleries link is awkward, and the galleries displayed don't link to the piclens slideshows. If you can tell me how to make this nice, I would so appreciate it. I run a small design studio, at www.witsend.cc and please tell me if there's anything that you like of my work, I'm happy to offer you anything for the help that you've already offered me, you have re-opened my eyes to the power of open source software.
Regards,
A
p.s. your ffmpeg module for Gallery totally works, and the upgrade gave me full audio and playback function. Yay


 
Profile Email
Quote
suprsidr
 November 23 2009 05:30 AM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

If I get some time the next few days, I'll take a look.
I'm hosting turkey day and have a ton to do before then.

-s


There will always be...
 
Profile Email Website
Quote
webmayin
 November 24 2009 17:36 PM  
Forum Junior
Junior

Status: offline

Registered: 09/18/09
Posts: 27

Thanks so much. I'm sure all the drupal users would appreciate some insight to tidying up the links on this amazing software of yours. It is truly an incredible array of opportunities. What I'd really like some insight to is how to allocate links for a user's profile page to their various albums, and a method of finding variables to pass with url rewrite turned on in the embedded gallery. If the E2 proplayer could become a standard block that showed up on all the users' pages, and reference their material in specific, people would have a really easy time keeping all their material available nicely. In the meantime, I'm going to spend the next few days looking over this glfusion you so recommended. Thanks again for your fine work.
Happy turkey day,
A


 
Profile Email
Quote
Content generated in: 0.62 seconds
New Topic Post Reply



 All times are PST. The time is now 04:27 PM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Anonymous users can post 
HTML Allowed 
Censored Content