Forum Index > FlashYourWeb OS Support > MiniSlide Show New Topic Post Reply
 Problem with 'MiniSlide Show'
 |  Printable Version
Anonymous: Joachim
 February 08 2010 09:57 AM (Read 1048 times)  


Hello,

first of all, nice program ;-)

but, i have a problem installing it.


What have i done?

I have a working gallery2 installation --> '%root_dir%/Modules/g2data'

I have a file named 'test.php' in the '%root_dir' dir ;-)

PHP Formatted Code
<embed src="Modules/g2data/minislideshow.swf" width="160" height="160"
 align="middle" pluginspage="http://www.macromedia.com/go/getflashplayer"
type="application/x-shockwave-flash" name="minislide" wmode="transparent"
 allowFullscreen="true" allowScriptAccess="always" quality="high"
flashvars="xmlUrl=Modules/g2data/mediaRss.php?mode=dynamic%26g2_view=dynamicalbum.RandomAlbum"></embed>
<noembed>Generated By <a href="http://www.flashyourweb.com/staticpages/index.php?page=embed-o-rator" target="_blank">The Acme MiniSlideShow EMBED-O-RATOR</a></noembed>


i the two files (mediaRss.php, minislideshow.swf) in the '%root_dir%/Modules/g2data' dir.
my mediaRss.php file contains:
PHP Formatted Code

    /* Connect to gallery */
    function init (){
            require_once( 'embed.php');
            $ret = GalleryEmbed::init(array('fullInit' => true, 'embedUri' => '/Modules/g2data/main.php', 'g2Uri' => '/Modules/g2data/'));
            if ($ret) {
                print 'GalleryEmbed::init failed, here is the error message: ' . $ret->getAsHtml();
                exit;
            }
            GalleryEmbed::done();
    }

there's a lot at the bottom of the mediaRss.php file, but i didn't change anything in there.

The only thing i get now if i browse to my test.php file is the java applet, but there are no images comming up Frown

Can anyone tell me what i am doing wrong?

Greetings, Joachim


 
Quote
suprsidr
 February 08 2010 10:02 AM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

use the full url to the minislideshow.swf and mediaRss.php

also to use mode=dynamic you need to have gallery's dynamic albums module installed/active.

-s


There will always be...
 
Profile Email Website
Quote
Anonymous: Joachim
 February 08 2010 10:19 AM  


Thank you Smile

works perfect Smile


 
Quote
Content generated in: 0.17 seconds
New Topic Post Reply



 All times are PST. The time is now 04:21 AM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Anonymous users can post 
HTML Allowed 
Censored Content