Forum Index > FlashYourWeb OS Support > MiniSlide Show New Topic Post Reply
 Does Version 4 pull by keyword?
 |  Printable Version
Anonymous: globelily
 January 09 2014 13:19 PM (Read 6364 times)  




Hi,
I've been using your mini-slideshow for years and love it but want to make the switch to version 4 so slideshows work on apple mobile devices. I feel dumb ... not getting the exact steps to make it work. Looks like the embed-o-rator doesn't help folks like me with the new version, only the old. Is that correct? Can the new version display by keyword like the old version? If so, can you show me a sample how the code should look?

Advice appreciated!

Laura


 
Quote
Anonymous: globelily
 January 09 2014 13:20 PM  



p.s. I am still using Gallery 2 and hope to embed the slideshow in wordpress posts.

thanks


 
Quote
suprsidr
 January 09 2014 13:43 PM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

Sure, you'll have to use the rest.php option:

PHP Formatted Code

<div id="mini-json">
    <strong>Javascript required to view this content.</strong>
</div>
 

PHP Formatted Code

<script>
$('#mini-json').minislideshow({
    provider: 'rest',
    url: 'http://testr.suprsidr.com/rest.php?mode=dynamic&g2_view=keyalbum.KeywordAlbum&g2_keyword=beach&maxSize=640',
    width: 640,
    height: 480,
    delay: 4,
    fontscale: 22,
    fullsize: true,
    resize: true
});
</script>
 

the above code works
http://codepen.io/suprsidr/pen/hFoyD


you should be able to adapt any of these http://www.flashyourweb.com/staticpages/index.php?page=mini_2.0.5#mediaRss

-s


There will always be...
 
Profile Email Website
Quote
Anonymous: globelily
 January 09 2014 14:23 PM  




Thank you for the speedy reply. Glad to know it can do what I want. Now I just need to make it work! I think perhaps I am not putting things in the right places. Please excuse my ignorance... I really don't know anything about jquery.

I put the rest.php file in my gallery2 root (which is just called gallery)

I put both the downloaded scripts inside their js directory, also in the gallery2 root

Here is the code in my wordpress post (that doesn't work ... I just see the loading image rolling around):

PHP Formatted Code
<div id="mini-json">
<strong>Javascript required to view this content.</strong>
</div>

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.js"></script>
<script src="http://drivingforwardlookingback.com/gallery/js/jquery.minislideshow.4.0.min.js"></script>

<script>
$('#mini-json').minislideshow({
    provider: 'rest',
    url: 'http://drivingforwardlookingback.com/gallery/rest.php?mode=dynamic&g2_view=keyalbum.KeywordAlbum&g2_keyword=summer,2009,california,&maxSize=498',
    width: 498,
    height: 334,
    delay: 4,
    fontscale: 22,
    fullsize: true,
    resize: true
});
</script>


If you can tell me what to change to make it work I will be so happy!

Thanks,

Laura


 
Quote
Anonymous: globelily
 January 09 2014 14:28 PM  




In the event it is helpful, here is the same keyword slideshow in the old version that is working.

PHP Formatted Code

<embed width="498" height ="334" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" name="minislide" wmode="transparent" quality="high" flashvars="xmlUrl=http://www.drivingforwardlookingback.com/gallery/mediaRss.php?mode=dynamic%26g2_view=keyalbum.KeywordAlbum%26g2_keyword=summer,2009,california,%26g2_maxImageWidth=492%26g2_maxImageHeight=492&useFull=true&showControls=always&autoStart=false&loop=false&noLink=true&delay=5&transInType=Fade&transOutType=Fade" src="http://www.drivingforwardlookingback.com/gallery/minislideshow.swf"/>


Laura


 
Quote
suprsidr
 January 09 2014 15:17 PM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

Issue is that rest.php is returning urls not formatted for javascript. I've only seen this once before.

So use jquery.minislideshow.4.0.js instead of jquery.minislideshow.4.0.min.js and edit line 191:

PHP Formatted Code

.attr({'src': o.url.replace(/&amp;/g, '&'), 'alt':
 

http://codepen.io/suprsidr/pen/waxFL

-s


There will always be...
 
Profile Email Website
Quote
Anonymous: globelily
 January 09 2014 15:46 PM  




Well, your reply got me excited that it was going to work with your suggested modification. Certainly I can see it is working for you! I modified jquery.minislideshow.4.0.js on line 191 and re-uploaded it, and changed the script I was calling to it but, alas, still no slideshow in my wordpress post. Is all of the code below supposed to be entered into the post as pasted below?

PHP Formatted Code
<div id="mini-json">
<strong>Javascript required to view this content.</strong>
</div>

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.js"></script>
<script src="http://drivingforwardlookingback.com/gallery/js/jquery.minislideshow.4.0.js"></script>

<script>
$('#mini-json').minislideshow({
    provider: 'rest',
    url: 'http://drivingforwardlookingback.com/gallery/rest.php?mode=dynamic&g2_view=keyalbum.KeywordAlbum&g2_keyword=summer,2009,california,&maxSize=498',
    width: 498,
    height: 334,
    delay: 4,
    fontscale: 22,
    fullsize: true,
    resize: true
});
</script>


Thanks for your help!

Laura

p.s. Here is a link to the test post that isn't working with new version on top and old version on bottom. I have tried removing the old one just in case somehow they conflicted. Didn't matter.

http://ourhousehaswheels.com/?p=1902 Would it matter that the wordpress blog and the gallery install are in different domains?


 
Quote
suprsidr
 January 09 2014 15:57 PM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

page not found.


There will always be...
 
Profile Email Website
Quote
Anonymous: globelily
 January 09 2014 16:03 PM  



My apologies. Forgot I hadn't published the page publicly since it was just a test page. That has been remedied.

http://ourhousehaswheels.com/?p=1902


 
Quote
suprsidr
 January 09 2014 16:23 PM  
Forum Admin
Admin

Status: offline

Registered: 12/20/06
Posts: 1221

You would likely not need to include jquery in your post as your site probably already includes it.
but you may need to enable js in posts
http://codex.wordpress.org/Using_Javascript#JavaScript_in_Posts

-s


There will always be...
 
Profile Email Website
Quote
Anonymous: globelily
 January 09 2014 16:34 PM  



that looks like it will involve some research and trial and error. will check back in and let you know if anything works.

thanks again

laura


 
Quote
Content generated in: 0.74 seconds
New Topic Post Reply



 All times are PST. The time is now 09:38 PM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Anonymous users can post 
HTML Allowed 
Censored Content